Windows 10 und Matrox Grafikkarten

Juchu! Windows 10! Nach einem trotz kleiner Problemchen geglückten Start auf meinem Heim-PC (Probleme mit dem nvidia-Grafiktreiber und Bitdefender, der eine Reparaturinstallation wollte, damit er wieder lief), habe ich es heute auf meinem Arbeits-PC probiert. Die Installation glückte auch hier soweit problemlos, nur am Grafiktreiber haperte es. Da Windows 10 selbst keinen Treiber für Matrox-Grafikkarten – zumindest nicht für die von mir genutzte M9138 – mitbringt, wurde hier ein Microsoft Standardtreiber installiert. Schon blöd, wenn man dann plötzlich nur noch einen Monitor zur Verfügung hat, statt der gewohnten drei (die im Übrigen auch schon fast zu wenig sind).

Weiterlesen

USB 3.0 Ethernet-Adapter an MacBook

Seit einiger Zeit ärgere ich mich damit herum, dass USB 3.0 Ethernet-Adapter an MacBooks (sowohl Pro als auch Air) mit Mavericks und Yosemite oftmals nicht korrekt funktionieren. Zumindest dann, wenn man nicht die originalen Apple Adapter verwendet, sondern bspw. die von Moshi. Die Symptome sind wie folgt:

  • Ist der Adapter während des Bootvorgangs schon eingesteckt, wird er vom System nicht erkannt, oder es kann keine Verbindung aufgebaut werden.
  • Geht das MacBook in den Ruhezustand, wird anschließend der Adapter nicht mehr erkannt oder es kann keine Verbindung mehr aufgebaut werden.
  • Nach ein paar Minuten Betrieb bricht plötzlich die Netzwerkverbindung weg.

Dann muss man ihn abstecken und wieder anstecken, damit er erkannt wird bzw. die Netzwerkverbindung neu aufgebaut wird.
Weiterlesen

[Tech-Tipp] Windows 8.1 Ruhezustand Monitor-Bug

In den letzten Tagen beschäftigte mich ein merkwürdiges Problem bei einem DELL Inspiron 15 mit Windows 8.1. Ging der Laptop nach 15 Minuten in den Ruhemodus, konnte das Display nicht reaktiviert werden. Eine Verbindung per RDP konnte nicht wirklich hergestellt werden (das Bild blieb schwarz), aber bspw. mit mmc, psexec oder über die administrativen Freigaben konnte ich auf den Laptop zugreifen. Um wieder richtig mit dem Gerät arbeiten zu können, war ein Hard-Reset nötig.

Nachdem ein Update aller Grafikkartentreiber nichts brachte, musste ich die Lösung an anderer Stelle suchen. Da ich die Original-Festplatte gegen eine (auch von DELL bezogene) SSD getauscht hatte, wollte ich nun ein eventuelles Kompatibilitätsproblem ausschließen und baute die ursprüngliche Platte wieder ein. Dort war noch der Werkszustand vorhanden, also Windows 8 ohne weitere Updates. In diesem Zustand funktionierte der Ruhemodus tadellos. Auch nach der Installation sämtlicher verfügbarer Windows-Updates inklusive der von Windows Update bereitgestellten Treiberupdates funktionierte der Ruhemodus so, wie er sollte.

Nach dem Upgrade auf Windows 8.1 war das Problem plötzlich da. Die meisten in Internetforen erwähnten Tipps (Treiber aktualisieren, Kennwortabfrage bei Reaktivierung deaktivieren usw.) haben nicht geholfen. Da sich das Problem doch relativ gut auf die Grafikkarte und somit genauer auf die verbaute ATI-Grafikkarte eingrenzen ließ (das Catalyst Control Center konnte nicht gestartet werden), habe ich es sogar mit den aktuellen Beta-Treibern von ATI ausprobiert, doch auch hier gab es keine Änderung am Verhalten. Ebenso half auch kein Update der Intel Chipsatz-Treiber und der Treiber für die integrierte Intel-Grafikkarte.

Der letzte Schritt, nämlich die Deaktivierung des Ruhemodus durch „powercfg -h off“ (hierzu muss die Kommandozeile mit Admin-Rechten gestartet werden; danach ein Neustart), konnte das Problem mehr oder weniger beseitigen. Es ist zwar nur ein Workaround, weil der Ruhemodus anschließend ja ausgeschaltet ist, wichtiger ist aber, dass man den Laptop wieder reaktivieren kann, wenn die Energiespar-Optionen greifen. Vermutlich hilft es auch, den Energie-Plan auf „Höchstleistung“ zu setzen und den Bildschirm nie ausschalten zu lassen.

Offenbar betrifft dieses Problem hauptsächlich Laptops, die neben der integrierten Intel-Grafik noch eine zusätzliche ATI-Grafikkarte verbaut haben. Jedenfalls konnte ich das soweit durch Internetrecherche eingrenzen. Sehr wahrscheinlich ist der ATI-Treiber an diesem Problem schuld. Auf allen anderen Laptops (ohne ATI-Grafik), die ich hier getestet habe, tritt das Problem nicht auf. Andererseits kann es auch sein, dass Windows 8.1 Probleme damit hat, wenn zwei Grafikkarten unterschiedlicher Hersteller verbaut sind. Letztendlich kann man nur abwarten, ob es dafür irgendwann einen Windows-Patch oder einen passenden ATI-Treiber gibt.

Canon-Drucker und Mac OS X

Wer einen Canon-Drucker wie bspw. den PIXMA iX5000 als Netzwerkdrucker unter Mac OS X installieren möchte, wird Probleme bekommen. Denn es gibt nicht für alle Drucker einen Netzwerk-Treiber, der mitgeliefert wird. Auch von Canon gibt es offiziell keinen Treiber, den man herunterladen kann, um den Drucker übers Netzwerk anzuschließen.

Leider weiß auch der Canon-Support wenig bescheid über dieses Thema und hat mich erstmal an den Hersteller des Printservers verwiesen, da das Problem dort zu suchen sei (würde allerdings nicht erklären, warum es keinen Netzwerk-Treiber für den Drucker gibt).

Dort habe ich allerdings auf der Homepage den Hinweis gefunden, dass man seinen Mac am besten mit dem aktuellen Paket der Gutenprint-Treiber ausstattet. Wenn man dann über „Systemeinstellungen“ -> „Drucken“ -> [+] -> „IP-Drucker“ die Drucker-IP eingibt, als Warteschlange „L1“ eingibt und dann den passenden Gutenprint-Treiber auswählt, gibt es keine Probleme mehr mit dem Drucker.

Gutes Gelingen!